WordPress错误:wp-settings.php on line 137

错误描述:WordPress在后台进行版本升级时,出错,之后进入前台或者后台,都无法访问进入,错误信息如下:

Warning: require(/wp-includes/class-wp-embed.php) [function.require]: failed to open stream: No such file or directory in /wp-settings.php on line 137

Fatal error: require() [function.require]: Failed opening required ‘/wp-includes/class-wp-embed.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /wp-settings.php on line 137

解决办法:

一、通过FTP或者相关主机商提供的文件管理工具,进入到 wp-content/themes,找到现在正在使用主题的文件夹重命名文件夹,在原文件夹名称后加入“-old”(不包括引号)。尝试是否恢复,否,进入下一步。

二、通过FTP或者其他文件管理工具,或者phpMyAdmin,重新设定插件文件夹(wp-content/plugins),类似上步骤。尝试是否恢复,否,进入下一步。

三、

1. 备份数据库、备份原网站文件。

2. 进入WordPress官网,下载最新安装包。

3. 解压,上传覆盖原程序。

4. 在浏览器地址栏键入WordPress升级程序地址:http://你的网站地址/wp-admin/upgrade.php ,按照步骤升级。

5. 即可。

发表评论

电子邮件地址不会被公开。 必填项已用*标注